Fable - Degraded Performance – Incident details

All systems operational

Degraded Performance

Resolved
Degraded performance
Started over 2 years agoLasted 4 days
Updates
  • Resolved
    Resolved

    Deno Deploy colds start times range from 300ms to 1.2s, Fable used to add more to those due to the initialization step of a few dependencies, but this was eliminated, and now all requests should be responded to within an average of 600ms. Of course, there will always still be cases where this isn't true but that should be very rare and dependent on the status of Deno.

  • Update
    Update

    We have implemented some big changes to our image proxy.

    Please report to us immediately if you encounter issues with character and anime images.

  • Monitoring
    Monitoring

    After a lot of coding and testing, we decided to not move Fable to Cloudflare.

    We'll be splitting Fable into multiple smaller services and optimizing the speed of each service as much as possible.

    Join our discord for more technical details.

  • Update
    Update

    We'll be slowly migrating parts of Fable to Cloudflare over the next week, no downtime is expected.

  • Identified
    Identified

    Our server provider's performance has been beyond unacceptable for the past week or so. we are looking into moving our servers to a different platform.

    In the meantime please excuse issues like messages failing or getting stuck on the loading spinner forever.